Partial outage due to upstream service distruption

Incident Report for CuttingRoom

Resolved

CuttingRoom is not seeing any issues anymore.
Posted Oct 21, 2025 - 05:30 CEST

Monitoring

The service is operating normally, but some issues can still be expected as the upstream service provider still has some impaired services.
Posted Oct 21, 2025 - 00:35 CEST

Identified

We still see intermittent problems with authentication because of the issues with the upstream service provider. We're continuing to monitor the situation.
Posted Oct 20, 2025 - 20:29 CEST

Investigating

We are currently experiencing issues with an upstream service provider. The authentication service is experiencing issues, and users may need to log in several times before they can open CuttingRoom.
Posted Oct 20, 2025 - 16:24 CEST
This incident affected: CuttingRoom Editor (USA).