Web application login

Incident Report for CuttingRoom

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 07:00 CEST

Investigating

We’re currently investigating an issue where some customers are unable to log in or use the web application. Our team is working to restore normal service as quickly as possible.
Posted Sep 04, 2025 - 06:30 CEST
This incident affected: CuttingRoom Editor (Australia).